User Tools

Site Tools


mikrotik

Setting up Mikrotik

Mikrotik is a software based router platform with a very easy to use Windows & web based administration panel.

It supports GRE, IPSEC, IPIP, SIT, etc, tunneling protocols as well as many routing protocols like BGP, & OSPF.

Initial Setup

You must set your CPU to 'QEMU' under the settings tab of Stallion, set the ethernet driver to Intel E1000, and finally set the disk driver to 'IDE'. Please see the below image as an example.

After this just go through the installer screens. If you need help with this please open a support ticket.

Network Setup

Sometimes DHCP doesn't connect properly so you should configure your networking manually. Please follow these steps to connect to the internet.

1) Enter the IP management section of the configuration

/ip address

2) Remove any automatically generated IP addresses

remove [find where interface="ether1"]

3) Assign your BuyVM IP address. You can view this in the control panel.

add address BUYVM_IP_ADDRESS/24 interface="ether1"

4) Access the routing table so we can get our default route in place

/ip route

5) Remove any automatically learnt static routes

remove [find]

6) Add our default route so we can ping the outside world. The Gateway IP can be found in Stallion under the “IP Addresses” tab.

add dst-address=0.0.0.0/0 gateway=BUYVM_GATEWAY_IP

7) Disable the DHCP client so it doesn't potentially cause issues in the future

/ip dhcp-client
remove [find]

8) Last but not least, set our resolvers so we can contact domains. You can find out which resolvers you should be using from the “IP Addresses” tab in Stallion.

/ip dns
set allow=yes
set servers=BUYVM_RESOLVER_IP

You should now be able to 'ping google.com' and get replies.

mikrotik.txt · Last modified: 2013/09/30 13:34 by Francisco Dias